POJ1145总结

Tree Summing

题目来源

Description

LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.
Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.


Binary trees are represented in the input file as LISP S-expressions having the following form.


empty tree ::= ()

tree ::= empty tree (integer tree tree)

The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

Note that with this formulation all leaves of a tree are of the form (integer () () )

Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.

Input

The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.

Output

There should be one line of output for each test case (integer/tree pair) in the input file. For each pair I,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.

Sample Input

22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
10 (3 
     (2 (4 () () )
        (8 () () ) )
     (1 (6 () () )
        (4 () () ) ) )
5 ()

Sample Output

yes
no
yes
no
#include<stdio.h>

int n,flag;

char inputFilter(){
	char c;
	while (scanf("%c",&c)&&c==' '||c=='\n'||c==9||c==10);
	return c;
}
//(5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
int dfs(int sum,int height){
	char c;
	int sign=1;//防止负数
	int count=0;
	c=inputFilter();//c的可能取值是),-,数字,不可能只左括号,左括号已经被读掉了 
	if (c==')') return height;//如果是),说明这个节点是空直接返回,如果不是,就需要继续处理 
	if (c=='-'){// 如果是-号,需要对数进行操作 
		sign=-1;
		c=inputFilter();
	}
	while (c>='0'&&c<='9'){
		count=count*10+sign*(c-'0');
		scanf("%c",&c);
	}
	if (c=='\n'||c==' ') c=inputFilter();//读到左子树的左括号,准备处理左子树 
	int left=dfs(sum+count,height+1);
	c=inputFilter();//读到右子树的左括号,准备处理右子树 
	int right=dfs(sum+count,height+1);
	c=inputFilter();//将这个节点读完
	if (left==height+1&&right==height+1){
		if (sum+count==n) flag=1;
	}
	
	return 0;
}

int main(){
	while (scanf("%d",&n)!=EOF){
		flag=0;
		inputFilter();//读掉第一个左括号
		dfs(0,0);
		if (flag==1){
			printf("yes\n");
		} else{
			printf("no\n");
		}
	}
	return 0;
}

发表评论