Perfect Cubes
Description
For hundreds of years Fermat’s Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the “perfect cube” equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.
Input
One integer N (N <= 100).
Output
The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.
Sample Input
24
Sample Output
Cube = 6, Triple = (3,4,5) Cube = 12, Triple = (6,8,10) Cube = 18, Triple = (2,12,16) Cube = 18, Triple = (9,12,15) Cube = 19, Triple = (3,10,18) Cube = 20, Triple = (7,14,17) Cube = 24, Triple = (12,16,20)
我的代码
先暴力a,在从小到大依次暴力b、c、d。这一题只有四个运算数以至于可以直接写四个循环。
#include<stdio.h>
int n,a,triple[4];
int cube[101];
void dfs(int step){
if (step==3) {
if (cube[a]==cube[triple[1]]+cube[triple[2]]+cube[triple[3]]){
printf("Cube = %d, Triple = (%d,%d,%d)\n",a,triple[1],triple[2],triple[3]);
}
}
else{
for (int i=triple[step];i<a;i++){
triple[step+1]=i;
dfs(step+1);
}
}
}
int main()
{
scanf("%d",&n);
triple[0]=2;
for (int i=0;i<=n;i++){
cube[i]=i*i*i;
}
for (int i=3;i<=n;i++){
a=i;
dfs(0);
}
return 0;
}