POJ1256总结

Anagram

题目来源

Description

You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word “abc”, your program should – by exploring all different combination of the three letters – output the words “abc”, “acb”, “bac”, “bca”, “cab” and “cba”.
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.
So the right order of letters is ‘A'<‘a'<‘B'<‘b'<…<‘Z'<‘z’.

我的代码

一开始没有读明白题目的意思,以为就是按照ASCII的顺序排列就可以了。我心想有这种好事?直接上STL就行了啊。然后果断WA了。实际上还是按照字典顺序,只不过大写的比小写的要优先。

求这种全排列的,只要按照大小顺序计数,再回溯就可以了。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n,len;
char s[15];
int ans[15];
int num[60];

void initialize(){
	for (int i=0;i<len;i++){
		if (s[i]>='a'){
			num[(s[i]-'a')*2+1]++;
		}else{
			num[2*(s[i]-'A')]++;
		}
	}
	
}

void traceback(){
	for (int i=0;i<len;i++){
		if (ans[i]%2==1){
			printf("%c",(char)((ans[i]-1)/2+'a'));
		}else{
			printf("%c",(char)(ans[i]/2+'A'));
		}
	}
	printf("\n");
}

void dfs(int step){
	if (step==len+1){
		traceback();
	}else{
		for (int i=0;i<52;i++){
			if (num[i]>0){
				num[i]--;
				ans[step-1]=i;
				dfs(step+1);
				num[i]++;
			}
		}
	}
}

int main()
{
	scanf("%d",&n);
	while (n--){
		scanf(" %s",s);
		len=strlen(s);
		memset(num,0,sizeof(num));
		memset(ans,0,sizeof(ans));
		initialize();
		
		for (int i=0;i<52;i++){
			if (num[i]>0){
				ans[0]=i;
				num[i]--;
				dfs(2);
				num[i]++;
			}
		}
	}
	return 0;
}

发表评论