Moo Volume
Description
Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.
FJ’s N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.
Input
* Line 1: N
* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).
Output
There are five cows at locations 1, 5, 3, 2, and 4.
Sample Input
5 1 5 3 2 4
Sample Output
40
Hint
INPUT DETAILS:
There are five cows at locations 1, 5, 3, 2, and 4.
OUTPUT DETAILS:
Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
我的代码
两只牛之间叫一次需要被计算两次,现在就先只计算一段距离,结果乘以二就是最终答案。
先对所有牛按照坐标升序排序,每次加入一头牛。在第i头牛加入战场时,它造成的噪音是(i-1)*它的坐标-前(i-1)头牛的坐标之和。这个证明画个图就出来了。
#include<stdio.h>
#include<algorithm>
using namespace std;
int locations[1000010];
long long sum;
long long ans;
int main()
{
int n;
scanf("%d",&n);
for (int i=0;i<n;i++){
scanf("%d",&locations[i]);
}
sort(locations,locations+n);
sum=locations[0];
ans=0;
//要开long long
for (long long int i=1;i<n;i++){
ans+=i*locations[i]-sum;
sum+=locations[i];
}
printf("%lld\n",ans*2);
return 0;
}
反思
这个数据量很大,实际上要开longlong才能过。