POJ2192总结

Zipper

题目来源

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

我的代码

这一题和求两个字符串的最大公共子序列有异曲同工之妙,都是将两个字符串作为动态规划的两个维度。只不过这一题是表示的不是长度,而是dp[i][j]是否可以构造出目标字符串的前i+j个。

dp方程是:

if (i>0) if (dp[i-1][j]==1&&s1[i-1]==t[i+j-1]) dp[i][j]=1;
if (j>0) if (dp[i][j-1]==1&&s2[j-1]==t[i+j-1]) dp[i][j]=1;
#include<stdio.h>
#include<string.h>

int main()
{
	int n;
	int dp[205][205];
	char s1[205],s2[205],t[405];
	scanf("%d",&n);
	for (int k=1;k<=n;k++){
		memset(dp,0,sizeof(dp));
		scanf(" %s %s %s",s1,s2,t);
		int len1=strlen(s1);
		int len2=strlen(s2);
		dp[0][0]=1;
		for (int i=0;i<=len1;i++){
			for (int j=0;j<=len2;j++){
				if (i>0) if (dp[i-1][j]==1&&s1[i-1]==t[i+j-1]) dp[i][j]=1;
				if (j>0) if (dp[i][j-1]==1&&s2[j-1]==t[i+j-1]) dp[i][j]=1;
			}
		}
		printf("Data set %d: ",k);
		if (dp[len1][len2]==1) printf("yes\n");
		else printf("no\n");
	}
	return 0;
}

发表评论