POJ1276总结

Cash Machine

题目来源

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

我的代码

这题金钱的取值范围太大了,如果将这题转化为01背包,时间显然会爆掉,所以要用二进制优化一下,把多重背包问题转化成面值为1,2,4…ni-2^k的单独的货币。

此外这一题空间也能会爆掉,所以还要优化空间。

#include<stdio.h>

int main()
{
	int cash,n;
	while (scanf("%d",&cash)==1)
	{
		scanf("%d",&n);
		int ni,di,num=0;
		int bag[100];
		int dp[100000]={0};
		for (int i=0;i<n;i++)
		{
			scanf("%d%d",&ni,&di);
			int temp=1;
			while(ni>temp)
			{
				bag[num++]=temp*di;
				ni=ni-temp;
				temp=temp*2;
			}
			if (ni!=0) bag[num++]=ni*di;
		}
		for (int i=0;i<num;i++)
		{
			for (int j=cash;j>=0;j--)
			{
				if (bag[i]<=j) dp[j]=dp[j]>dp[j-bag[i]]+bag[i]?dp[j]:dp[j-bag[i]]+bag[i];
			}
		}
		printf("%d\n",dp[cash]);
	}
	return 0;
}

反思

空间优化过后遍历cash时要降序遍历,否则会导致一个货币用了两次的情况。

发表评论