POJ1042总结

Gone Fishing

题目来源

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,…,n – 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n – 1 integers ti (1 <=i <=n – 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

我的代码

遍历所有鱼塘作为本次最远达到的池塘,计算得到可以钓鱼的次数(分钟数/5)chance。然后将所经过的所有池塘能钓到的鱼的数量都放入一个优先队列,每次弹出队首元素更新结果,并更新这个池塘下一次能钓到的鱼的数量(如果不够减di就设置为0),再放入队列中。一共取chance次。

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;

struct pool
{
	int num,fish;
	
	bool operator<(const pool &a)const
	{
		if(fish==a.fish)
		return (num>a.num);
		else return fish<a.fish;
	}
	
	pool(int num,int fish):num(num),fish(fish){}
};

int n,h,f[30],d[30],t[30];
int main()
{
	while(scanf("%d",&n)&&n!=0)
	{
		memset(f,0,sizeof(f));
		memset(d,0,sizeof(d));
		memset(t,0,sizeof(t));
		int sumTime[30]={0};
		int res[30];
		int exception=-1;
		
		scanf("%d",&h);
		h=h*12;
		
		for (int i=0;i<n;i++)
		{
			scanf("%d",&f[i]);
		}
		for (int i=0;i<n;i++)
		{
			scanf("%d",&d[i]);
		}
		for (int i=0;i<n-1;i++)
		{
			scanf("%d",&t[i]);
			sumTime[i+1]=sumTime[i]+t[i];
			
		}
		
		for (int i=n-1;i>=0;i--)
		{
			if (sumTime[i]>h) continue;
			
			int chance=h-sumTime[i];
			int temp[30]={0};
			int tempAns=0;
			priority_queue<pool> q;
			for (int j=0;j<=i;j++)
			{
				q.push(pool(j,f[j]));
			}
			
			while(chance--)
			{
				pool t=q.top();
				q.pop();
				temp[t.num]++;
				tempAns+=t.fish;
				if(t.fish>d[t.num]) q.push(pool(t.num,t.fish-d[t.num]));
				else q.push(pool(t.num,0));
			}
			
			
			if(tempAns>exception)
			{
				exception=tempAns;
				for (int j=0;j<=i;j++) res[j]=temp[j];
				for (int j=i+1;j<n;j++) res[j]=0;
			}
			else if(tempAns==exception)
			{
				for (int j=0;j<=i;j++)
				{
					if (temp[j]<res[j]) break;
					else if (temp[j]>res[j])
					{
						exception=tempAns;
						for (int j=0;j<=i;j++) res[j]=temp[j];
						for (int j=i+1;j<n;j++) res[j]=0;
						break;
					}
				}
			}
		}
		
		for (int i=0;i<n-1;i++)
		{
			printf("%d, ",res[i]*5);
		}
		printf("%d \n",res[n-1]*5);
		printf("Number of fish expected: %d \n\n",exception);
	}
	
	return 0;
}

为了保证最后的结果序号小的池塘呆的时间最长,首先要先重写pool的运算符以保证当五分钟能钓到一样数量的鱼时选择最小的序号的池塘:

struct pool
{
	int num,fish;
	
	bool operator<(const pool &a)const
	{
		if(fish==a.fish)
		return (num>a.num);
		else return fish<a.fish;
	}
	
	pool(int num,int fish):num(num),fish(fish){}
};

其次还要在更新最终的结果时,注意期望值相同的时候的处理:

if(tempAns>exception)
			{
				exception=tempAns;
				for (int j=0;j<=i;j++) res[j]=temp[j];
				for (int j=i+1;j<n;j++) res[j]=0;
			}
			else if(tempAns==exception)
			{
				for (int j=0;j<=i;j++)
				{
					if (temp[j]<res[j]) break;
					else if (temp[j]>res[j])
					{
						exception=tempAns;
						for (int j=0;j<=i;j++) res[j]=temp[j];
						for (int j=i+1;j<n;j++) res[j]=0;
						break;
					}
				}
			}
		}

反思

这一题还能用dp来做:dp[i][j]表示第j个五分钟时John位于池塘 i 的情况最多可以钓到多少鱼。

dp方程为dp[i][j] = max(dp[i][j], dp[i – 1][j – t[i] – k]+sum[i][k]);。其中sum[i][k]是在第i个鱼塘钓k个五分钟所能得到的鱼的数量。

发表评论