POJ2021总结

Relative Relatives

题目来源

Description

Today is Ted’s 100th birthday. A few weeks ago, you were selected by the family to contact all of Ted’s descendants and organize a surprise party. To make this task easier, you created an age-prioritized list of everyone descended from Ted. Descendants of the same age are listed in dictionary order.

The only materials you had to aid you were birth certificates. Oddly enough, these birth certificates were not dated. They simply listed the father’s name, the child’s name, and the father’s exact age when the baby was born.

Input

Input to this problem will begin with line containing a single integer n indicating the number of data sets. Each data set will be formatted according to the following description.

A single data set has 2 components:

  1. Descendant Count – A line containing a single integer X (where 0 < X < 100) indicating the number of Ted’s descendants.
  2. Birth Certificate List – Data for X birth certificates, with one certificate’s data per line. Each certificate’s data will be of the format “FNAME CNAME FAGE” where:
    • FNAME is the father’s name.
    • CNAME is the child’s name.
    • FAGE is the integer age of the father on the date of CNAMEs birth.

Note:

  • Names are unique identifiers of individuals and contain no embedded white space.
  • All of Ted’s descendants share Ted’s birthday. Therefore, the age difference between any two is an integer number of years. (For those of you that are really picky, assume they were all born at the exact same hour, minute, second, etc… of their birth year.)
  • You have a birth certificate for all of Ted’s descendants (a complete collection).

Output

For each data set, there will be X+1 lines of output. The first will read, “DATASET Y”, where Y is 1 for the first data set, 2 for the second, etc. The subsequent X lines constitute your age-prioritized list of Ted’s descendants along with their ages using the format “NAME AGE”. Descendants of the same age will be listed in dictionary order.

Sample Input

2
1
Ted Bill 25
4
Ray James 40
James Beelzebub 17
Ray Mark 75
Ted Ray 20

Sample Output

DATASET 1
Bill 75
DATASET 2
Ray 80
James 40
Beelzebub 23
Mark 5

我的代码

这个题目的分类是数据结构,于是我用stl构造了一个极其复杂但是时间效率很高的算法(O(n)),利用bfs从根结点开始将所有的儿子结点的年龄算出来。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include <vector>
#include<string>
#include<map>
#include<queue>
#include <functional>
using namespace std;
bool cmp(const pair<string, int>& a, const pair<string, int>& b) {
        if (a.second!=b.second)
			return a.second > b.second;
		else
			return a.first<b.first;	
}

int main()
{
	int t;
	scanf("%d",&t);
	for (int o=1;o<=t;o++)
	{
		printf("DATASET %d\n",o);
		map<string,int> person;//给每一个人一个序号
		map<string,int> age;//记录每一个人的年龄 
		queue<string> prede;//队列bfs所有人算出年龄 
		vector<string> dec[100];//记录每一个人的后代 
		person["Ted"]=1;
		int x,fage,index=2;
		int exact[101][101]={0};//记录两个人之间的年龄差 
		string fname,cname;
		scanf("%d",&x);
		for (int i=0;i<x;i++)
		{
			cin>>fname>>cname>>fage;
			if (person.find(fname)==person.end()) person[fname]=index++;
			if (person.find(cname)==person.end()) person[cname]=index++;
			dec[person[fname]].push_back(cname);
			exact[person[fname]][person[cname]]=fage;
		}
		
		prede.push("Ted");
		age["Ted"]=100;
		while (!prede.empty())
		{
			string now=prede.front();
			prede.pop();
			for (int i=0;i<dec[person[now]].size();i++)
			{
				age[dec[person[now]][i]]=age[now]-exact[person[now]][person[dec[person[now]][i]]];
				prede.push(dec[person[now]][i]);
			}
		}
		/*
		map<string,int>::iterator it = age.begin();
		while(it != age.end()) 
		{
			cout<<it->first<<" "<<it->second<<endl;
			it++;
		}
		*/
		vector<pair<string, int> > vec(age.begin(), age.end());//结果,为了使用送人头排序 
	    sort(vec.begin(), vec.end(), cmp);
	    for (int i = 1; i < vec.size(); ++i)
	        cout << vec[i].first << " "<<vec[i].second<< endl;
		}
}

反思

实际上看来别人的代码,直接用两个循环暴力出结果,用的也是bfs,但是数据结构要简单很多。这一题数据范围不大,用暴力也是可以接受的。

发表评论