POJ1163总结

The Triangle

题目来源

Description

        7
      3   8
    8   1   0
  2   7   4   4
4   5   2   6   5

   (Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

我的代码

每一个位置都可以往左下方走或者右下方走,也就是说每一个位置都可以由左上方或者右上方来产生。dp方程为dp[i][j]=tri[i][j]+max(dp[i-1][j-1],dp[i-1][j])

#include<stdio.h>
int max(int x,int y)
{
	return x>y?x:y;
}
int tri[101][101]={0};
int dp[101][101];
int main()
{
	int n;
	scanf("%d",&n);
	for (int i=1;i<=n;i++)
	{
		for (int j=1;j<=i;j++)
		{
			scanf("%d",&tri[i][j]);
		}
	}
	dp[1][1]=tri[1][1];
	for (int i=2;i<=n;i++)
	{
		for (int j=1;j<=i;j++)
		{
			dp[i][j]=tri[i][j]+max(dp[i-1][j-1],dp[i-1][j]);
		}
	}
	int ans=0;
	for (int i=1;i<=n;i++)
	{
		ans=max(ans,dp[n][i]);
	}
	printf("%d",ans);
	return 0;
}

反思

经典的杨辉三角问题。

发表评论