POJ1143总结

Number Game

题目来源

Description

Christine and Matt are playing an exciting game they just invented: the Number Game. The rules of this game are as follows.
The players take turns choosing integers greater than 1. First, Christine chooses a number, then Matt chooses a number, then Christine again, and so on. The following rules restrict how new numbers may be chosen by the two players:

  • A number which has already been selected by Christine or Matt, or a multiple of such a number,cannot be chosen.
  • A sum of such multiples cannot be chosen, either.

If a player cannot choose any new number according to these rules, then that player loses the game.
Here is an example: Christine starts by choosing 4. This prevents Matt from choosing 4, 8, 12, etc.Let’s assume that his move is 3. Now the numbers 3, 6, 9, etc. are excluded, too; furthermore, numbers like: 7 = 3+4;10 = 2*3+4;11 = 3+2*4;13 = 3*3+4;… are also not available. So, in fact, the only numbers left are 2 and 5. Christine now selects 2. Since 5=2+3 is now forbidden, she wins because there is no number left for Matt to choose.
Your task is to write a program which will help play (and win!) the Number Game. Of course, there might be an infinite number of choices for a player, so it may not be easy to find the best move among these possibilities. But after playing for some time, the number of remaining choices becomes finite, and that is the point where your program can help. Given a game position (a list of numbers which are not yet forbidden), your program should output all winning moves.
A winning move is a move by which the player who is about to move can force a win, no matter what the other player will do afterwards. More formally, a winning move can be defined as follows.

  • A winning move is a move after which the game position is a losing position.
  • A winning position is a position in which a winning move exists. A losing position is a position in which no winning move exists.
  • In particular, the position in which all numbers are forbidden is a losing position. (This makes sense since the player who would have to move in that case loses the game.)

Input

The input consists of several test cases. Each test case is given by exactly one line describing one position.
Each line will start with a number n (1 <= n <= 20), the number of integers which are still available. The remainder of this line contains the list of these numbers a1;…;an(2 <= ai <= 20).
The positions described in this way will always be positions which can really occur in the actual Number Game. For example, if 3 is not in the list of allowed numbers, 6 is not in the list, either.
At the end of the input, there will be a line containing only a zero (instead of n); this line should not be processed.

Output

For each test case, your program should output “Test case #m”, where m is the number of the test case (starting with 1). Follow this by either “There’s no winning move.” if this is true for the position described in the input file, or “The winning moves are: w1 w2 … wk” where the wi are all winning moves in this position, satisfying wi < wi+1 for 1 <= i < k. After this line, output a blank line.

Sample Input

2 2 5
2 2 3
5 2 3 4 5 6
0

Sample Output

Test Case #1
The winning moves are: 2

Test Case #2
There's no winning move.

Test Case #3
The winning moves are: 4 5 6

我的代码

如果选某一个数字时必赢的,那就说明选完这个数字之后无论再选什么都是必输的;如果是必输的,那么无论选了什么数字之后,都存在一个数字可以赢。利用这个规律进行搜索,同时结合状态压缩,将所有的数字选择状态进行压缩,并将对应结果存在dp数组中以用于记忆搜索。

dp[i]=1表示状态i的情况下可以必赢,dp[i]=-1表示无论如何都必输,dp[i]=0表示不确定。dfs()为选择一个数字之后进行递归,返回值为0时表示当前无论选什么都输,返回值为1时表示可以赢。

#include<stdio.h>
#include<string.h>
int n,num,count=0;
int exist[21];
int ans[21];
int dp[1<<20];
int getbin(int now[])
//将当前的数字选择情况进行状态压缩 
{
	int res=0;
	for (int i=2;i<21;i++)
	{
		if (now[i])	res=res|1;
		res=res<<1;
	}
	return res;
}
int dfs(int fore[],int t)
{
	int now[21];
	now[t]=0;
	for (int i=2;i<21;i++)
	{
		now[i]=fore[i];
	}
	for (int i=2;i<21;i++)
	//将不可选的数字剔除 
	{
		if (!now[i])
		{
			if ((i+t)<21) now[i+t]=0;
		}
		if (i%t==0)	now[i]=0;
	}
	int state=getbin(now);
	if (dp[state])
	{
		if (dp[state]==1)
		{
			return 1;
		}
		else return 0;
	}
	for (int i=2;i<21;i++)
	{
		if (now[i]&&!dfs(now,i))
		{
			dp[state]=1;
			return 1;
		}
	}
	dp[state]=-1;
	return 0;
}
int main()
{
	scanf("%d",&n);
	memset(dp,0,sizeof(dp));
	while (n!=0)
	{
		count++;
		memset(exist,0,sizeof(exist));
		memset(ans,0,sizeof(ans));
		
		num=0;
		int temp;
		for (int i=0;i<n;i++)
		{
			scanf("%d",&temp);
			exist[temp]=1;
		}
		for (int i=2;i<21;i++)
		{
			if (exist[i]&&!dfs(exist,i))
			{
				ans[num++]=i;
			}
		}
		printf("Test Case #%d\n",count);
		if (num==0)	printf("There's no winning move.");
		else
		{
			printf("The winning moves are:");
			for (int i=0;i<num;i++)
			{
				printf(" %d",ans[i]);
			}
		}
		printf("\n\n");
		scanf("%d",&n);
	}
	return 0;
 } 

反思

状态压缩+记忆化搜索的第一次实战!

发表评论