POJ1083总结

Moving Tables

题目来源

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

我的代码

将走廊按照房间的位置分成200块,上下的两个房间占用的都是同一个块,那么可以把整个走廊压缩为一维序列。对于每一次的搬运,都可以看作对走廊块的占用,只需要计算出所有的走廊块被占用的最多次数即可。利用差分法。

#include<stdio.h>
#include<string.h>
int weight[201];
int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		memset(weight,0,sizeof(weight));
		int n,begin,end;
		scanf("%d",&n);
		for (int i=0;i<n;i++)
		{
			scanf("%d%d",&begin,&end);
			if (begin>end)
			{
				int temp=begin;
				begin=end;
				end=temp;
			}
			//编号为k的房间占用的走廊块号是(k-1)/2 
			weight[(begin-1)/2]++;
			weight[(end-1)/2+1]--;
		}
		int ans=weight[0];
		for (int i=1;i<201;i++)
		//差分法求每个块的占用次数 
		{
			weight[i]+=weight[i-1];
			if (weight[i]>ans)	ans=weight[i];
		}
		printf("%d\n",10*ans);
	}
	return 0;
}

反思

这道题分类给的是动态规划,但是我不能明白如何用动规去解决。

发表评论