POJ1936总结

All in All

题目来源

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

我的代码

由于是要求是否存在子序列,每一个字母都不要求连续,所以要求的子串中的字母只需要按照先后顺序出现一次就可以了。在遍历final string的每一个字母时,依次寻找有没有出现子串的字母,如果出现了,就去寻找子串的下一个字母。

#include<stdio.h>
#include<string.h>

char s[100010],t[100010];

int main()
{
	while(scanf(" %s %s",s,t)==2)
	{
		int lens=strlen(s);
		int lent=strlen(t);
		int tag=0;
		for (int i=0;i<lent;i++)
		{
			if (s[tag]==t[i]) tag++;
		}
		if (tag!=lens) printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}

发表评论