POJ1915总结

Knight Moves

题目来源

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

我的代码

简单宽搜。

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;

struct node{
	int x,y,step;
	node(){
	}
	node(int x,int y,int step):x(x),y(y),step(step){
	}
};

const int dir[8][2]={{1,2},{1,-2},{-1,2},{-1,-2},{2,1},{2,-1},{-2,1},{-2,-1}};
int n,l,sx,sy,tx,ty,dx,dy,ans=-1;
int flag[301][301];
node temp;
queue<node>q;

int check(int x,int y){
	if (x>=0&&x<l&&y>=0&&y<l){
		return 1;
	}else{
		return 0;
	}
}

int main()
{
	scanf("%d",&n);
	while(n--){
		memset(flag,0,sizeof(flag));
		while(!q.empty()) q.pop();
		scanf("%d",&l);
		scanf("%d%d",&sx,&sy);
		scanf("%d%d",&tx,&ty);
		q.push(node(sx,sy,0));
		flag[sx][sy]=1;
		while (true){
			if (!q.empty()){
				temp=q.front();
				q.pop();
				if (temp.x==tx&&temp.y==ty){
					ans=temp.step;
					break;
				}
				for (int i=0;i<8;i++){
					dx=temp.x+dir[i][0];
					dy=temp.y+dir[i][1];
					if (check(dx,dy)){
						if (!flag[dx][dy]){
							q.push(node(dx,dy,temp.step+1));
							flag[dx][dy]=1;
						}
					}
				}
			}else{
				break;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

发表评论