POJ1456总结

Supermarket

题目来源

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

我的代码

由于所有任务的最早可开始时间都一致,那问题就突然变得明朗起来。只要按照时间的倒序来选择商品就好。deadline递减,每一次遍历都将可以在这个ddl处卖出的商品加入到按价值降序的优先队列中,如果队列不空,那么每一个单位时间都选择队首的货物售出。

要注意的是deadline的最少时间是1。

#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;

struct product{
	int p,d;
	bool operator<(const product &a) const
	{
		return p<a.p;
	}
	
	product(int p,int d):p(p),d(d){}
	product(){}
};

bool cmp(product a, product b)
{
	return a.d>b.d;
}
int main()
{
	int n;
	while (scanf("%d",&n)==1)
	{
		int ddl=0;
		int now=0;
		int ans=0;
		product products[10001];
		priority_queue<product> q;
		for (int i=0;i<n;i++)
		{
			scanf("%d%d",&products[i].p,&products[i].d);
		}
		sort(products,products+n,cmp);
		ddl=products[0].d;
		while(ddl>0)
		{
			while(products[now].d>=ddl&&now<n)
			{
				q.push(product(products[now].p,products[now].d));
				now++;
			}
			if (!q.empty())
			{
				product temp=q.top();
				q.pop();
				ans+=temp.p;
			}
			ddl--;
		}
		printf("%d\n",ans);
	}
	return 0;
}

反思

网上有利用并查集的方法来实现的。思路是每次都选择价值最大的商品,如果能被安排在时间线上就安排在所有可行的时间点上的最后一个。用并查集来压缩所有已经被选择过的时间点的路径。也是一个好思路。

发表评论