POJ1323总结

Game Prediction

题目来源

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

我的代码

田忌赛马思路。要求我最少能赢多少场合,就相当于求别人最多赢多少场合。

找到别人手中n*(m-1)张卡片中最大的前n张作为上等马,其余的都可以看作是下等马。如果别人手中所有的上等马中没有能够打赢我的马的就用他们的下等马来碰我的上等马。

#include<stdio.h>
#include<algorithm>

using namespace std;

bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int m,n;
	int cnt=0;
	while (scanf("%d%d",&m,&n)==2&&m!=0)
	{
		cnt++;
		int head=0,ans=0;
		int mine[50];
		int others[50];
		for (int i=0;i<n;i++)
		{
			scanf("%d",&mine[i]);
		}
		sort(mine,mine+n,cmp);
		int k=0,now=m*n;
		for (int i=0;i<n;i++)
		{
			while (mine[k]==now&&k<n&&now>0)
			{
				k++;
				now--;
			}
			others[i]=now;
			now--;
		}
		for (int i=0;i<n;i++)
		{
			if (others[head]>mine[i])
			{
				head++;
			}
			else
			{
				ans++;
			}
		}
		printf("Case %d: %d\n",cnt,ans);
	}
	return 0;
}

发表评论