POJ2029总结

Get Many Persimmon Trees

题目来源

Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as ‘Mishirazu Persimmon’, were planted. Since persimmon was Hayashi’s favorite fruit, he wanted to have as many persimmon trees as possible in the estate given by the lord.
For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded by the solid line contains the most persimmon trees. Similarly, if the estate’s width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate’s width and height are 3 and 4 respectively, the area surrounded by the dotted line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.

Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

Input

The input consists of multiple data sets. Each data set is given in the following format.

N
W H
x1 y1
x2 y2

xN yN
S T

N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <= N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.

The end of the input is indicated by a line that solely contains a zero.

Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

Sample Input

16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0

Sample Output

4
3

我的代码

可以将果树看作1,空白土地看作0,这一道题转化为求最大的S*T的矩形内所有数字的和。利用二维前缀和来处理,S*T的矩形数字和为:

temp=sum[i+s-1][j+t-1]-sum[i-1][j+t-1]-sum[i+s-1][j-1]+sum[i-1][j-1];
#include<stdio.h>
#include<string.h>


int n,w,h,s,t,a,b;
int map[110][110];
int sum[110][110];//sumh[i][j]前i行前j列数的和


void initialize()
{
	for (int i=1;i<=w;i++)
	{
		for (int j=1;j<=h;j++)
		{
			sum[i][j]=map[i][j]+sum[i-1][j]+sum[i][j-1]-sum[i-1][j-1];
		}
	}
}

int main()
{
	while (scanf("%d",&n)==1&&n!=0)
	{
		int ans=-1,temp;
		scanf("%d%d",&w,&h);
		memset(map,0,sizeof(map));
		memset(sum,0,sizeof(sum));
		for (int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			map[a][b]=1;
		}
		scanf("%d%d",&s,&t);
		initialize();
		for (int i=1;i+s-1<=w;i++)
		{
			for (int j=1;j+t-1<=h;j++)
			{
				temp=sum[i+s-1][j+t-1]-sum[i-1][j+t-1]-sum[i+s-1][j-1]+sum[i-1][j-1];
				if (temp>ans) ans=temp;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

发表评论