POJ1458总结

Common Subsequence

题目来源

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

我的代码

模板。

#include<stdio.h>
#include<string.h>

int dp[1001][1001];
int main()
{
	char s1[1000];
	char s2[1000];
	while (scanf(" %s %s",s1,s2)==2)
	{
		memset(dp,0,sizeof(dp));
		int len1=strlen(s1);
		int len2=strlen(s2);
		for (int i=0;i<=len1;i++) dp[i][0]=0;
		for (int i=0;i<=len2;i++) dp[0][i]=0;
		for (int i=1;i<=len1;i++)
		{
			for (int j=1;j<=len2;j++)
			{
				if (s1[i-1]==s2[j-1]) dp[i][j]=dp[i-1][j-1]+1;
				else 
				{
					dp[i][j]=dp[i-1][j]>dp[i][j-1]?dp[i-1][j]:dp[i][j-1];
				}
			}
		}
		printf("%d\n",dp[len1][len2]);
	}
	return 0;
}

反思

初始状态是从字符串长度为0开始的。

POJ如果代码没有用到std的命名空间,写上using namespace std;编译时会报错。

发表评论