POJ2063总结

Investment

题目来源

Description

John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
Assume the following bonds are available:

ValueAnnual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow.
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).
The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

我的代码

完全背包问题。需要做的优化是,由于每一种理财产品的价格都是1000的倍数,所以背包的容量(总金额)可以除1000后再计算。

#include<stdio.h>
#include<string.h>

int n,start,year,d,temp;
int dp[50005];
struct bond{
	int value;
	int intrest;
	bond(){
		value=0;
		intrest=0;
	}
};
int main()
{
	scanf("%d",&n);
	while(n--){
		scanf("%d%d%d",&start,&year,&d);
		bond bonds[15];
		for(int i=0;i<d;i++){
			scanf("%d%d",&bonds[i].value,&bonds[i].intrest);
			bonds[i].value=bonds[i].value/1000;
		}
		for (int y=0;y<year;y++){
			memset(dp,0,sizeof(dp));
			temp=start/1000;
			for (int i=0;i<d;i++){
				for (int j=bonds[i].value;j<=temp;j++){
					dp[j]=dp[j]>dp[j-bonds[i].value]+bonds[i].intrest?dp[j]:dp[j-bonds[i].value]+bonds[i].intrest;
				}
			}
			start+=dp[temp];
		}
		printf("%d\n",start);
	}
	return 0;
}

发表评论