POJ2033总结

Alphacode

题目来源

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages:

Alice: “Let’s just use a very simple code: We’ll assign ‘A’ the code word 1, ‘B’ will be 2, and so on down to ‘Z’ being assigned 26.”
Bob: “That’s a stupid code, Alice. Suppose I send you the word ‘BEAN’ encoded as 25114. You could decode that in many different ways!”
Alice: “Sure you could, but what words would you get? Other than ‘BEAN’, you’d get ‘BEAAD’, ‘YAAD’, ‘YAN’, ‘YKD’ and ‘BEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.”
Alice: “How many different decodings?”
Bob: “Jillions!”

For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of ‘0’ will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6
89
1

我的代码

设dp[i]为前i个数字能构成多少种解密结果,第i个数字它有两种可能的情况,一是自己单独就能解密出一个字母,二是和第i-1个数字联合起来解密出一个字母,所以dp方程是dp[i]=dp[i-1]+dp[i-2]。但是由于并不是所有的数字都能对应解密出一个字母,所以需要排除很多种情况。

如果第i个数是0,其自身不能对应一个字母,只能与第i-1个联合;如果第i个和第i-1个数字表示的值小于1或大于26,它们不能联合。

#include<stdio.h>
#include<string.h>

int num[10100];
long long int dp[10100];
char s[10100];

int main()
{
	scanf(" %s",s);
	while (strcmp(s,"0")!=0)
	{
		int len=strlen(s);
		dp[0]=1;dp[1]=1;
		for (int i=2;i<=len;i++)
		{
			if (s[i-1]=='0') dp[i]=dp[i-2];//单引号
			else{
				dp[i]=dp[i-1];
				if (s[i-2]!='0'&&(s[i-2]-'0')*10+s[i-1]-'0'<=26) dp[i]+=dp[i-2];
			}
		}
		printf("%lld\n",dp[len]);
		scanf(" %s",s);
	}
	return 0;
}

发表评论